Issue 'tabbing' through an attribute

If you have questions or if you want to share your opinion about Aware IM post your message on this forum
Post Reply
Jhstephenson
Posts: 273
Joined: Wed Apr 22, 2015 11:44 pm

Issue 'tabbing' through an attribute

Post by Jhstephenson »

Has anyone ever run across this...

On a form I have a number of date attributes that look like this:
pd_case_dates.png
pd_case_dates.png (9.97 KiB) Viewed 241 times
Everything works great except for when I try to tab on the 'Date Filed' attribute. Nothing happens. The cursor doesn't move and the only way to get to the next field is to click on it.

So, I thought maybe I just needed to delete it and then add it back in.

I deleted that attribute and then put it into test mode. Now the attribute labeled 'Date Appointed' acts just like the 'Date Filed' one did. I can click on the field, I can enter data, or select from the Date Control, but I cannot tab off of the attribute.

So, I add the 'Date Filed' attribute back to the form. Now the 'Date Appointed' attribute works just like it should. I can tab into it, I can tab out of it. Just like I would want.

But, the 'Date Filed' attribute acts just like it did before. I cannot tab past it. The only way out of it is to click on the next attribute.

Any thoughts on what might be happening here?

Thanks,
Jim
eagles9999
Posts: 2281
Joined: Mon Jul 02, 2012 12:24 am
Location: Ulaanbaatar, Mongolia

Re: Issue 'tabbing' through an attribute

Post by eagles9999 »

I assume you have set the Tab order in each of the Attribute Properties?
Cheers,
Mark
_________________
AwareIM 6.0, 8.6, 8.7 (build 2941) MariaDB, Windows 10, Ubuntu Linux. Theme: Default, Browser: Chrome, Edge
Upcloud
Image
Jhstephenson
Posts: 273
Joined: Wed Apr 22, 2015 11:44 pm

Re: Issue 'tabbing' through an attribute

Post by Jhstephenson »

Yes. Tab order is set correctly. I checked that a couple of times.

The really odd part is taking out the Date Filed attribute caused the issue to move to another attribute. Put it back in and the problem went back to the Date Filed attribute.
nhofkes
Posts: 67
Joined: Mon Sep 07, 2020 6:03 am
Location: Netherlands

Re: Issue 'tabbing' through an attribute

Post by nhofkes »

Have you tried tabbing multiple times to see where you end up? I have experienced that when you have attributes in multiple columns (like you seem to have in this form), the tab after the last attribute on the left column brings the focus to the buttons that may be present at the top toolbar instead of the attributes in the right column on the form. If you then press tab multiple times, you may ultimately get back to the attribute on the right.

You could try to move the Date Filed attribute to the left hand side on the form (below Date Appointed) and see what happens.
Niels
(V8.7 build 3025 - MariaDB - Windows)
Post Reply