Unable to connect to my application securely in HTTPS

If you have questions or if you want to share your opinion about Aware IM post your message on this forum
Post Reply
Maxo42
Posts: 46
Joined: Sun Dec 04, 2022 11:13 pm

Unable to connect to my application securely in HTTPS

Post by Maxo42 »

Hello everybody.

I currently host my Aware IM app on a Windows VPS with Amazon. The app works great when I use it on the internet at the domain address that points to my IP address. However, the application is not secure because it is not in HTTPS. So for everything to be safe I have activated an SSL certificate which works well on my Windows server as you can see on the screenshot where we see that I can go to the login box without problem and we can see that the page is secure with the small padlock.
Capture d’écran 2023-05-12 155944.png
Capture d’écran 2023-05-12 155944.png (29.51 KiB) Viewed 75813 times
On the other hand, when I connect to one of my applications I receive this as a message (see screenshot below.)
Capture d’écran 2023-05-12 160314.png
Capture d’écran 2023-05-12 160314.png (36.51 KiB) Viewed 75813 times
And when I try to go to the page where I can connect directly to an application, I receive this as a message (see screenshot below).
Capture d’écran 2023-05-12 160456.png
Capture d’écran 2023-05-12 160456.png (70.83 KiB) Viewed 75813 times
Is it not working because my Aware IM apps are running with their own server which is Tomcat server and if that is the problem, Is there anyone hosting their Windows apps with Amazon who can tell me how to get my AwareIM apps to work over HTTPS.

Thanks for your help.
Post Reply